PortChanel(静的LAG mode=on)を組んだポートにLAGを組まないポートからケーブルを1本だけ差しても疎通できるか確認してみました

PortChanel(静的LAG mode=on)を組んだポートにLAGを組まないポートからケーブルを1本だけ差しても疎通できるか
ググっても出てこないので確認してみました。

1.背景
Windowsサーバのチーミング方式を選択する際に、
WindowsサーバをDVDブートでイメージバックアップからネットワーク越しにリストアする時に、 LACPの設定が出来ないので、選択肢として
A.スイッチ依存無しでActive-Standby(送受信は片方のNICのみ使用)
B.静的チーミング(送受信とも2ののNICを使用)
の2つがあると聞いて、 AはDVDブート時に普通にIP設定してやれば出来るということは容易に想像できましたが、 BはDVDブート時にIP設定しただけで、疎通できるの?
という疑問が沸いたので、Cisco Catalyst2960Sをヤフオクで落札して
実際に試してみることにしました。

2.試験環境

WindowsPC:192.168.0.194
ルータ:192.168.0.1
スイッチ(vlan1):192.168.0.150
Port1(vlan1):自宅LAN環境への接続
Port13/14(vlan1):静的LAG(mode=on)

3.試験方法

スイッチのPort13,14で静的LAG(mode=on)を組んで、
WindowsPC(192.168.0.194)のケーブルをスイッチのPort13に差して、
ルータ(192.168.0.1)にpingが飛ぶか確認する。

4.試験手順
4-1.スイッチに静的LAG(mode=on)の設定をする

Switch01#configure terminal

Switch01(config)#interface range gigabitEthernet 1/0/13 , gigabitEthernet 1/0/14
Switch01(config-if-range)#channel-group 1 mode on
Switch01(config-if-range)#no shutdown
Switch01(config-if-range)#exit
Switch01(config)#

Switch01#show etherchannel summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

    M - not in use, minimum links not met
    u - unsuitable for bundling
    w - waiting to be aggregated
    d - default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) – Gi1/0/13(P) Gi1/0/14(D)

Switch01#show running-config

interface GigabitEthernet1/0/13
switchport mode access
channel-group 1 mode on

interface GigabitEthernet1/0/14
switchport mode access
channel-group 1 mode on

ポート13,14でLAGが組まれていることがわかります。

4-2.疎通テスト(ping)

WindowsPC(192.168.0.194)のケーブルをスイッチのPort13に差して、
WindowsPC(192.168.0.194)からルータ(192.168.0.1)にpingを飛ばします。

C:\Users\xxxxx>ping 192.168.0.1

192.168.0.1 に ping を送信しています 32 バイトのデータ:
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.0.1 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 0ms、最大 = 0ms、平均 = 0ms

疎通できました!

WindowsPC(192.168.0.194)のケーブルをスイッチのPort13から抜いて、Port14に差し直して、
WindowsPC(192.168.0.194)からルータ(192.168.0.1)にpingを飛ばします。

C:\Users\xxxxx>ping 192.168.0.1

192.168.0.1 に ping を送信しています 32 バイトのデータ:
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64
192.168.0.1 からの応答: バイト数 =32 時間 <1ms TTL=64

192.168.0.1 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 0ms、最大 = 0ms、平均 = 0ms

こちらもやはり疎通できました!

5.まとめ
PortChanel(静的LAG mode=on)を組んだポートにLAGを組まないポートからケーブルを1本だけ差しても
疎通できることが確認できました。
これにより、スイッチ側の設定を触らずにWindowsサーバのDVDブートからのネットワーク越しのイメージリストア
をするには、チーミング方式をLACP以外の
A.スイッチ依存無しでActive-Standby(送受信は片方のNICのみ使用)
B.静的チーミング(送受信とも2ののNICを使用)
の2つの選択肢があることが確認できました。

Comments are closed.